Payroll Import: Transferring Payroll Entries to Connected

Modified on Tue, Sep 15 at 11:34 AM

Knowledge Base · Payroll

Applies to: Connected 11.1+  |  Platform: Desktop & Cloud


This article reviews the process of transferring payroll entries, from a separate software or payroll service, into the Connected Accounting and ERP software.

Some examples of external payroll providers are ADP, Connected US Online Payroll, Paychex, EasyPay, Ceridian, or QuickBooks Online Payroll.

A summary of the import process is as follows:

  • Open the Payroll Import window
  • Use the Payroll Import Account Mapping to map payroll codes to your Connected General Ledger accounts. This only has to be done once unless changes are needed.
  • Choose the import mapping method.
  • Import payroll entry and verify the results.

ARTICLE CONTENTS

  1. Mapping a Payroll Import File to Connected
  2. Importing the Payroll File into Connected
  3. Posting the Payroll Entry and Updating the Bank Reconciliation
  4. Related Articles
  5. Reference Links

NOTE

If you have already mapped your payroll file, skip to the Importing the Payroll File into Connected section of this document.

1. Mapping a Payroll Import File to Connected

Before a payroll file can be imported, it must first be mapped. This process is typically required once, unless new accounts are added. Mapping of the payroll file is done within the Payroll Import window, as described in the steps below.

  1. Select File → Import → Payroll.
  2. The following Import Payrollscreen will appear.
  3. Before importing the first time, click the Payroll Import Account Mapping button, as shown in the above screen. The Payroll Import G/L Account Mapping will appear so that the payroll system G/L code can be mapped to the corresponding value in Connected. A sample payroll mapping is shown in the following screen.
  4. Once the Accounts have been mapped, click OK to close the mapping window. In the Payroll Import window, select from one of the following options, explained below.

1.1  Use Default Mapping

Choose this option, if the payroll import file uses the default format (below). The default import format is as follows:

  1. Date - Journal entry date; required; must be in an open accounting period; all import records should have the same value
  2. Account No - required; must have valid account number
  3. Account Description - 40 character max; if blank in the import, the standard G/L account description is used
  4. Debit - required; must be a positive number; see note below
  5. Credit - required; must be a positive number, see note below
  6. Journal Description - 1024 character max; all import records should have the same value

NOTE

  • A debit or credit amount is required for each account allocation and the total debits must balance the total credits.
  • Prior to the import, the import file payroll accounts must be mapped to Connected G/L accounts. The accounts mapped are retained for future imports.
  • Imported payroll details create a single, unposted journal entry.

1.2  Use Manual Mapping

Choose this option, if the payroll import file is not in the default import order. You can then choose to load an import file header to map the file fields. This is helpful if your file has extra data that can't be imported or is in a different order from the Connected default.

An example of a manually mapped file is shown in the the following screen.

Once the file has been mapped, it can be imported.

2. Importing the Payroll File into Connected

  1. Select File → Import → Payroll.
  2. The following Import Payroll screen will appear. The previous mapping selection (Default or Manual) will already be selected and configured.
  3. Click the Step 2: Preview & Import Data tab, as shown in the following screen.
    Step 2: Preview and Import Data tab in the Import Payroll window
  4. Under the Preview and Import Data tab, select from the following options:
    • a) Import File Contains a Header Row checkbox. In the payroll mapping example in the previous section the file had a header row so this will need to be selected. In most cases, it will need to be selected.
    • b) The Import from File button as shown in the screen below will prompt for a file and import directly without a preview.
    • c) The Preview from File button will load the import detail into the preview pane for review. This is the recommended option so the entry can be verified before import.
  5. The following screen shows the Preview from File option loaded in for preview. Click Import Previewed Data to proceed or Clear Preview to abort and either reload a new file or cancel the whole process.

  6. If the Import Previewed Data was selected, a green status bar will flash quickly to show the progress.
  7. When the import is completed, an OK message will appear that summarizes the results. Click OKto clear the message. Results of the import can be viewed in the bottom portion of the window, as shown in the following screen.

    NOTE

    Payroll entries are imported as unposted general journal entries. If an entry is imported that is incorrect, it can be deleted

  8. Close the window to exit the Payroll Import or continue to import another entry.

    A sample of the payroll journal entry created, unposted, is shown in the following screen:

3. Posting the Payroll Entry and Updating the Bank Reconciliation

Once the payroll has been imported Connected creates a single unposted journal entry. Before this entry is posted, it can be modified or deleted. After the entry is posted, it will appear with amounts and check numbers/payee names (if included on the import file) on the Bank Reconciliation.

4. Related Articles

5. Reference Links

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article